Back
Downtime

Budibase is currently unavailable

Started 6 Jun at 03:54pm BST, resolved 6 Jun at 04:02pm BST.

Login Apps Availability Builder Availability Availability Search
Resolved

All systems are operational

Posted 6 Jun at 04:02pm BST.
Created

Due to an issue relating to SSL certificates we are experiencing some unexpected downtime.

Posted 6 Jun at 03:54pm BST.