Back
Degraded

Some users are experiencing issues accessing Budibase

Started 6 Jun at 02:00pm BST, resolved 6 Jun at 04:02pm BST.

Login Apps Availability Builder Availability
Resolved

The root cause of the issue has been identified. For users still experiencing an issue relating to loading web assets we recommend first trying in a new browser or clearing your browser cache.

Posted 6 Jun at 04:02pm BST.
Created

Due to a change in caching behaviour we are seeing reports of some users being unable to load the Budibase Builder or Account portal.

Posted 6 Jun at 02:00pm BST.