Back
Downtime

Full platform outage

Started 3 Jul at 11:10am BST, resolved 3 Jul at 11:48am BST.

Sign up Login Apps Availability Builder Availability Automations Availability Search
Resolved

We have identified the issue and systems are now back to normal.

Posted 3 Jul at 11:48am BST.
Created

Budibase is currently unavailable for all of our users due to a production database issue. The team are working on a fix to restore.

Posted 3 Jul at 11:10am BST.