Back
Degraded

All services are running slow

Started 27 Mar at 10:45am GMT, resolved 27 Mar at 02:40pm GMT.

Sign up Login Apps Availability Builder Availability Automations Availability Search
Resolved

Services have returned to normal operations.

Posted 27 Mar at 02:40pm GMT.
Created

We’re currently experiencing degraded performance across all services. Our engineers believe this may be related to issues with our account portal licensing. The team is investigating the root cause and working on a fix. We’ll provide further updates as soon as we have more information.

We appreciate your patience.

Posted 27 Mar at 10:45am GMT.