Back
Downtime

Service unavailable

Started 29 May at 04:32pm BST, resolved 29 May at 05:35pm BST.

Sign up Login
Resolved

All services now restored

Posted 29 May at 05:35pm BST.
Updated

The last release has been rolled back and access to Budibase should now be restored for all existing users. A separate issue with signing up is ongoing.

Posted 29 May at 05:13pm BST.
Created

The most recent release has caused a problem with our sign up and log in functionality. The engineers are working to roll back the release.

Posted 29 May at 04:32pm BST.