Back
Resolved
Resolved
Investigating issues with our cloud service
Started , resolved .
Sign up
Login
Apps Availability
Builder Availability
Automations
Availability
Search
Resolved
Cloud experienced a service interruption caused by an underlying infrastructure issue. The issue resulted in degraded service availability for approximately 50 minutes before normal operations were restored.
Posted .
Created
All services are currently down; our engineering team is investigating the cause.
Posted .